Búsqueda aproximada en Excel – tercera nota

sábado, febrero 23, 2008

En las últimas dos notas vimos cómo encontrar en una lista el valor más cercano al valor buscado, o extraer el valor asociado a él.
La fórmula matricial que expusimos, y que he mejorado gracias al aporte de Natxo (ver comentario en la nota anterior), nos da el valor más cercano al valor buscado. A veces buscamos el mayor valor más cercano y a veces el menor. Por ejemplo, si observamos la tabla del ejemplo de la nota anterior



vemos que Pedro, con 76, es el más cercano al promedio, 76,2. Pero si buscamos quién tiene la calificación más cercana por encima del promedio, la respuesta es María con 79.

Esta fórmula matricial nos permite encontrar el valor más cercano por encima del valor buscado

={=INDICE($A$2:$A7;COINCIDIR(MIN(SI(B2:B7-B9>=0;B2:B7;FALSO));SI(B2:B7-B9>=0;B2:B7;FALSO);FALSO))}

Esta fórmula crea una matriz con las diferencias entre los valores de la lista y el valor buscado; luego encuentra el menor que sea mayor a cero, es decir, el más cercano que sea mayor al valor buscado.

De la misma manera, esta fórmula no da el valor más cercano que es menor que el buscado

={INDICE($A$2:$A7;COINCIDIR(MIN(SI(B2:B7-C9>=0;B2:B7;FALSO));SI(B2:B7-C9>=0;B2:B7;FALSO);FALSO))}

El archivo con las fórmulas se puede descargar aquí.


Technorati Tags:

4 comments:

Anónimo,  11 marzo, 2008 21:55  

Se que sonare de lo mas ignorante pero las formulas me las marca erroneas y no logro hacerlas funcionar. Me podrias dar una ayuda?. Gracias.

Jorge L. Dunkelman 11 marzo, 2008 23:09  

Estás poniendo las fórmulas apretando simultáneamente Ctrl+Mayusculas+Enter?
Ten en cuenta que son fórmulas matriciales.

JC 12 septiembre, 2008 19:55  

Hola:sos un genio.
te hago una consulta, tengo un archivo con un listado de facturas de proveedor que voy ingresando por dia,con su codigo de proveedro, con su fecha, Numero, e importe, yo quiero que en otra hoja se vaya actualizando automaticamente ordenada por codigo de proveedor las facturas con sus correspondientes subtotales, necesito que esten todas las facturas, desde ya muchas gracias.
masetro de los maestros.
sds JC

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP