Uso del Solver en Excel

domingo, marzo 19, 2006

For the english version of this post, press here.

Ayer hablamos sobre como usar Buscar Objetivo (Goal Seek) de Excel para resolver problemas dependientes de una sola variable. La funcionalidad Buscar Objetivo nos permite responder a la pregunta cuál debe ser el valor de una variable para obtener un determinado valor en una función (o fórmula).
Cuando queremos resolver problemas que dependen de más de una variable, la herramienta a usar es el Solver.
El Solver es un complemento de Excel (Add – In). Si no aparece en el menú Herramientas (inmediatamente debajo de Buscar Objetivo) hay que instalarlo.
Para esto hay que activar el menú Herramientas--->






Y señalar el Solver

Supongamos el siguiente problema (para
descargar el cuaderno del ejemplo apretar aquí):

Dados estos datos



Queremos armar la cartera de inversiones que maximice las ganancias, sujeto a la restricción de no invertir en cada tipo de inversión más de lo permitido.
Para resolver este problema con el Solver debemos primero construir un modelo:



Las fórmulas en el rango E7:E9 son =$C$3*D7;


en el rango F7:F9 son =E7*C7;
las celdas en el rango D7:D9 las dejamos vacías para recibir en ellas la solución del problema.

El siguiente paso es determinar los parámetros del solver:




Interpretamos el diálogo que se abre de la siguiente manera:

Set Target Cell to: la celda para la cual queremos encontrar la solución. En nuestro caso F10.

Equal to: en nuestro caso elegimos "Max", es decir, maximizar el resultado en F10 (que contiene la fórmula =SUMA(F7:F9))

Subject to Constraints: las condiciones del caso. Para introducir estas condiciones apretamos el botón Add.


En nuestro caso:

D10 = 1, ya que el total de las partes de la cartera no pueden superar el 100% de la cartera.

D7<=B7, para cumplir la condición que la inversión en este tipo de bien no supere lo establecido en la celda B7 D7<=0, para evitar que Solver nos de un resultado negativo, lo que sería cierto matemáticamente, pero carente de sentido en la realidad. De la misma manera procedemos con el resto de la condiciones.
Finalmente pulsamos "Solve". Se abre un diálogo donde Excel nos muestra la solución encontrada.



Para retener los resultados apretamos "Keep Solver Solution".



Categorías: Funciones&Formulas_, Varios_




Technorati Tags:

3 comments:

Alan 24 julio, 2008 02:15  

como siempre maestro, increíble su trabajo!!
muhas gracias por compartir sus conocimientos...

saludos desde México!

Edwin Arnaldo 31 diciembre, 2008 02:13  

Gracias por compartir tus conocimientos....Eres GRANDE...

En lo personal seguire leyendo tus blogs, Saludes y bendiciones

Anónimo,  30 noviembre, 2009 19:50  

Muchas gracias, una vez mas. El 70 por ciento de lo que se de excel lo he aprendido en su blog

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP