Cálculo de duración de procesos por turnos

lunes, noviembre 17, 2014

Los cálculos con fechas y horas en Excel suelen ser un tanto truculentos. Veamos por ejemplo esta consulta de una de mis lectoras:

Suponiendo que es 14-nov-14 8:00 am, tengo un proceso que dura 9 horas y mi turno dura 8 horas, cómo puedo hacer para que el día 15-nov-14 la hora de finalización sea 9:00am
Es decir, la tarea se realiza en un turno que empieza a las 08:00 AM y dura ocho horas. Si la tarea se extiende por más de ocho horas, ésta será completada el día siguiente.

La fórmula que nos permite hacer este cálculo es la siguiente

=SI(C5>C2,B5+TRUNCAR(C5/C2)+RESIDUO(C5,C2),B5+C5)

Veamos como funciona esta fórmula:

C5>C2 determina si el proceso puede completarse en las horas del turno;

B5 contiene la fecha y hora del comienzo del proceso;

TRUNCAR(C5/C2) nos calcula cuantos días debemos agregar a la fecha de iniciación del proceso para completarlo (múltiplos de la duración del turno);

RESIDUO(C5,C2) calcula cuántas horas debemos agregar a los múltiplos de ocho horas (la duración del turno).

De esta manera, si el proceso dura más de ocho horas, la función SI aplica la primer parte de la fórmula:

B5+TRUNCAR(C5/C2)+RESIDUO(C5,C2)



Las cosas se complican un poco (más) si queremos calcular la fecha de finalización del proceso tomando en cuenta sólo los días laborables.
Contamos para ello con la función DIA.LAB, es cierto, pero hay un pequeño problema. DIA.LAB no toma en cuenta las horas, sólo las fechas, como podemos ver en este ejemplo:


Dado que el 14/11/2014 cae un viernes, el próximo día laboral es el 17/11/2014 (lunes), pero podemos ver que la fórmula no toma en cuenta la hora de comienzo, sólo la fecha.
A pesar de esto podemos usar DIA.LAB para nuestro cálculo, de esta manera:

=SI(C5>C2,DIA.LAB(B5,TRUNCAR(C5/C2))+C1+RESIDUO(C5,C2),B5+C5)


donde C1 es la hora de comienzo del turno.



7 comments:

Manukino 18 noviembre, 2014 13:57  

Que bueno Jorge. Felicidades.

Anónimo,  30 marzo, 2017 13:10  

Muy buen post, muchas gracias por el aporte.
El único problema que veo es que esta fórmula solo funciona si el comienzo del turno y el comienzo de la tarea coinciden, de lo contrario, considera que el comienzo de la tarea es el mismo que el del turno, es decir, las 8:00.
¿Existe alguna fórmula para corregir esto?
Muchas gracias.

Jorge Dunkelman 30 marzo, 2017 14:50  

Hmmm...no me parece que exista ese problema. Por ejemplo, si ponemos 14/11/2014 10:00 en B5, la fórmula da como resultado 15/11/2014 11:00 lo que parece correcto.
EL primer día el proceso se realiza de las 10 de mañana hasta las 4 de la tarde, es decir, 6 horas. Quedan por lo tanto 3 horas para completar el proceso que empieza al día siguiente a las 8 de la mañana y concluye a las 11:00-

Anónimo,  30 marzo, 2017 15:44  

Muchas gracias por responder.
Considerando que la fecha de comienzo es el 10/11/2014 a las 8:00h (B5) y la duración de la tarea es de 9 horas (C5), la finalización da como resultado 11/11/2014 a las 9:00h (D5), es decir, 8 horas de la jornada del día 10 + 1 hora de la jornada del día 11. Al cambiar la hora de comienzo a las 10:00h (B5), el resultado de finalización (D5) no se modifica...

Jorge Dunkelman 30 marzo, 2017 19:00  

Tendrás que mandarme el archivo para que pueda ver qué es lo que no funciona. Cuando pruebo la fórmula con tus datos, todo funciona.
Una pregunta, ¿en la celda B5 pones la fecha + hora o solamente la hora?

Anónimo,  31 marzo, 2017 08:47  

En la celda B5 tengo la fecha + la hora...
¿A qué dirección puedo enviarte el archivo?
Muchísimas gracias por tu ayuda.

Jorge Dunkelman 31 marzo, 2017 15:23  

Fijate en ek enkcae Ayuda, en la parte superior del blog.

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP