Uso de comodines (wildcards) en funciones de Excel

sábado, agosto 20, 2011

Cuando filtramos tablas o hacemos búsquedas en Excel podemos usar comodines (*, ?). ¿Podemos usarlos en las funciones? Bien, sí y no. Es decir, hay funciones que aceptan comodines en los argumentos y otras que no.

Por ejemplo, queremos evaluar si una celda contiene cierto texto. En caso afirmativo el resultado será "A", en caso negativo "B".



Obviamente =SI(A1="*no*";"A";"B") no funciona.

Pero veamos esta alternativa



Como pueden ver, =SI(ESNUMERO(HALLAR("no";A1));"A";"B") no requiere comodines para nuestro ejemplo.

Podemos ver cómo funciona esta fórmula descomponiéndola en sus partes:



La función HALLAR da la primera posición en la cadena de texto del texto buscado

=HALLAR("no";A2)

Si el texto no aparece el resultado el #¡VALOR!

La función ESNUMERO evalúa si el resultado de HALLAR es numérico. Cuando lo es da VERDADERO, cuando no lo es, también si el error, da FALSO. Estos resultados son los argumentos que usamos en SI.

Veamos un ejemplo más elaborado donde buscamos valores que en la segunda posición contienen una "n" y en la cuarta posición una "o".



Como ven, en =SI(ESNUMERO(HALLAR("?n?o";A2));"A";"B") estamos usando el comodín "?" para señalar que la primera y la tercera posición puede ser ocupada por cualquier valor, pero la segunda y la cuarta deben ser "n" y "o" respectivamente.

La función COINCIDIR también acepta comodines.



También la función CONTAR.SI. Por ejemplo, en la lista anterior, si queremos contar todos los nombres que terminan con la letra "o" usamos

=CONTAR.SI($A$2:$A$7;"*o")



De la misma manera SUMAR.SI comodines pero SUMAPRODUCTO no.

3 comments:

Maneco 22 agosto, 2011 15:42  

Muy bueno! Como nos tienes acostumbrados...

Anónimo,  06 septiembre, 2012 19:34  

en los ejemplos de usos de comodines en ambos casos con las dos formulas no me da el resultado aparece error, inclusive copie la formula y aun asi, no se que pasa? Ayuda..

Jorge L. Dunkelman 07 septiembre, 2012 11:22  

¿Qué error (#NA, #ERROR, #REF, etc)? Si estás copiando la fórmula hay que tener en cuenta que, dependiendo de las definiciones regionales del sistema, el separador de argumentos en la función puede ser coma (,) o punto y coma (;).

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP