Suma interna de los dígitos de un número con Excel - ampliación

lunes, marzo 21, 2011

En mi nota anterior sobre la suma interna de los dígitos de un número, propuse esta fórmula para la tarea

=SUMAPRODUCTO(EXTRAE(A2,FILA(INDIRECTO("1:" & LARGO(A2))),1)*1)

También podemos usar

=SUMAPRODUCTO(--EXTRAE(A2,FILA(INDIRECTO("1:" & LARGO(A2))),1))

si preferimos usar la doble negación para convertir los valores VERDADERO o FALSO en 1 o 0.

El problema con esta fórmula es que cuando el resultado es un número de dos dígitos, tenemos que volver a aplicarla, ya sea anidando dos fórmulas o usando celdas auxiliares.

Con esta fórmula podemos realizar la suma interna de los dígitos de un número en una única operación:

=1+RESIDUO(SUMAPRODUCTO(--EXTRAE(A2,FILA(INDIRECTO("1:" & LARGO(A2))),1))-1,9)

Esta fórmula se base en el artificio matemático "Prueba del nueve" y fue propuesta por Rick Rothstein en un comentario en el sitio de Chandoo.

3 comments:

Anónimo,  06 julio, 2011 22:14  

Solo para actualizar, la fórmula en excel 2010 quedaría así:

=1+RESTO(SUMAPRODUCTO(--MED(A2,FILA(INDIRECTO("1:" & LARGO(A2))),1))-1,9)

Jorge L. Dunkelman 07 julio, 2011 16:54  

Gracias por aportar! Aclaremos que MED es el nuevo nombre de la función EXTRAE en Excel 2010.

Anónimo,  28 septiembre, 2014 07:06  

QUE EXCELENTE APORTACION MUCHAS GRACIAS

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP