Contar condicional distinguiendo entre mayúsculas y minúsculas

sábado, junio 13, 2009

La función CONTAR.SI no distingue entre minúsculas y mayúsculas cuando contamos las apariciones de una palabra o cadena de texto en un rango.

Por ejemplo, en el rango A1.A12 aparece la palabra “manzana”, siete veces escrita con mayúsculas (MANZANA) y cinco veces en minúsculas (manzana)



Contar condicional con mayusculas

Si queremos contar cuantas veces aparece MANZANA en el rango, estaríamos tentados a usar esta fórmula

=CONTAR.SI(A1:A12,"MANZANA")

El problema es que el resultado es 12, es decir, CONTAR.SI no distingue entre minúsculas y mayúsculas

Contar condicional con mayusculas

La solución consiste en usar la función IGUAL(). Esta función compara dos textos y da como resultado VERDADERO o FALSO, tomando en cuenta minúsculas y mayúsculas.


Como ya hemos explicado en el pasado, podemos forzar a Excel a convertir VERDADERO en 1 y FALSO en 0, multiplicando estos valores lógicos por 1 (o usándolos en alguna operación aritmética). Sobre esta base podemos escribir esta fórmula matricial


={SUMA(--IGUAL("MANZANA",A1:A12))}

Contar condicional con mayusculas

El doble signo “-“ a la izquierda de IGUAL tiene la función de convertir la matriz de VERDADERO y FALSO generada por la función en un vector de 1 y 0, que son sumados por la función SUMA.


Como toda fórmula matricial, ésta debe ser introducida apretando simultáneamente Ctrl+Mayusculas+Enter (lo que hace que aparezcan los corchetes).


Si reemplazamos “MANZANA” por “manzana”, veremos que el resultado es 5

Contar condicional con mayusculas




Technorati Tags:

10 comments:

Anónimo,  28 septiembre, 2009 03:06  

este es el blog más bueno gracias or compartir cuidate

Anónimo,  11 noviembre, 2009 21:05  

Excelente explicación y aporte.. Muchas gracias

mihai_doc 01 noviembre, 2010 02:46  

no hay forma de que me de...lo he intentado de 300 formas... en vez de manzanas y MANZANAS son m y M pero no puedo me da error de formula...

Jorge L. Dunkelman 01 noviembre, 2010 05:58  

¿Estás introduciendo la fórmula como fórmula matricial?
¿Qué tipo de error recibís?

mihai_doc 01 noviembre, 2010 14:50  

Hago lo mismo que en las fotos...incluso tomo los mismos tangos A1:a12...
escribo la formula sin corcheches y le doy a ctr may enter y me dice.
error de la formula.
-para obtener mas informacion..
-para obtener ayuda..
-si no desea introducir la formula..
he probado de varias maneras pero no encuentro la solucion.si me podrias ayudar desde ya gracias.

Jorge L. Dunkelman 01 noviembre, 2010 22:17  

Enviame el archivo por mail privado.

Jorge L. Dunkelman 02 noviembre, 2010 13:57  

mihai,
la dirección del mail figura en la nota Ayuda (el enlace en la pate superior del blog).

mihai_doc 02 noviembre, 2010 21:07  

muchisimas gracias me ha sido de gran ayuda...

gjf 15 febrero, 2011 09:53  

A mi me sucede como a Mijai, me indica que la sintaxis está mal. Podríais ayudarme ??

Jorge L. Dunkelman 15 febrero, 2011 09:58  

Como a Mijai, te sugiero que me envíes el archivo para que pueda revisarlo.

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP