Cómo evitar resultados #N/A en fórmulas de Excel

jueves, febrero 09, 2006

Cuando Excel no logra resolver una función, da como resultado #N/A (del inglés: not available). Hay situaciones en las cuales este resultado es aceptable, es decir, no hay solución, pero no quisiéramos que aparezca en la planilla.
Hay varias formas de evitar que este resultado sea visible. Una de ellas ya la he mostrado
en esta nota. Sencillamente seleccionamos los resultados #N/A con Ir A Especial, y borramos el contenido de las celdas seleccionados (Ctrl + Enter).

Otra forma es construir nuestra fórmula de tal manera que Excel no dé como resultado #N/A.

Veamos este ejemplo. Tenemos aquí dos listas, una con todos los nombres y una segunda con algunos nombres de los cuales queremos averiguar la edad





Si aplicamos la función BUSCARV (VLOOKUP) en nuestra fórmula, obtendremos dos valores #N/A en la tabla 2



Como comentario aparte, pueden ver que he utilizado un nombre (Lista_1) para señalar el rango de búsqueda. Siempre recomiendo esta técnica, como ya lo he hecho en
esta nota.

Volviendo a nuestro tema, como podemos evitar estos resultados?

A la fórmula =BUSCARV(D3,Lista_1,2,0) le agregamos una condición, tal que si el resultado esperado es #N/A, la fórmula dé como resultado un blanco.
Rescribimos nuestra fórmula de esta manera:


=SI(ESERROR(BUSCARV(D8,Lista_1,2,0))," ",BUSCARV(D8,Lista_1,2,0))

El resultado será el siguiente



Nuestra fórmula funciona de la siguiente manera:
La función SI (If en la versión inglesa) evalúa en primer lugar el resultado de la función ESERROR (IsError) cuya variable es la búsqueda que queremos realizar. Si el resultado es positivo, es decir el resultado será #N/A, la función SI dará un resulta en blanco (señalado por " "). En caso contrario dará el resultado de la búsqueda BUSCARV(D8,Lista_1,2,0).

Esta técnica es útil, por supuesto, en cualquier otra fórmula que use funciones de Excel.

Si te gustó esta nota anotala en del.icio.us



Technorati Tags: , ,



Categorías: Funciones&Formulas_, Varios_

36 comments:

Anónimo,  24 septiembre, 2007 20:42  

en la version 2007 de excel encontre la funcion =SI.ERROR(valor,"valor_si_error")esta me funciono para poder corregir el problema que aparezca #NA, la pagina me parece fabulosa, mi email es opcioneo@gmail.com, felicitaciones por la pagina

Anónimo,  24 septiembre, 2007 20:44  

en la version 2007 de excel encontre la funcion =SI.ERROR(valor,"valor_si_error")esta me funciono para poder corregir el problema que aparezca #NA, la pagina me parece fabulosa, mi email es opcioneo@gmail.com, felicitaciones por la pagina

Anónimo,  11 noviembre, 2007 21:23  

En el caso de excel 2003 la fórmula sufre una pequeña modificación: se deben reemplazar las comas por puntos y comas entre los argumentos.

Felicitaciones por la página.

Jorge L. Dunkelman 11 noviembre, 2007 22:12  

Hola,

el tipo de separador no tiene que ver con la versión de Excel, sino con las definiciones regionales del Windows.
Sucede que a veces escribo mis notas en el laptop, donde tengo definiciones "inglesas".
Gracias por las felicitaciones.

Anónimo,  29 mayo, 2008 04:32  

Muchas gracias por compartir sus conocimientos me han sido de mucha ayuda.

Juan Alberto 09 julio, 2008 23:57  

Felicitaciones:::!!!!

Gracias por la solución a mi gran problema con el famoso error DIV/0

Muy útil la ayuda.

MeteOritO 16 julio, 2008 16:39  

Excelente solucion.
yo estoy intentando adaptarlo a Dos formulas y no Puedo, aver si alguien me ayuda.
Estas son las Formalas que me dan resultado #N/A cuando no hay un valor de origen.

=INDICE(precio;COINCIDIR(A25;material;0))

=SI(E25<>"";REDONDEAR(E25*F25;2);"")

*La primera hace referencia a una lista de materiales que hace referencia a el precio correspondiente a veces en la plantilla no tengo que selecionar nada o escriber algo que no no tengo en la lista, entonces obtengo el #N/A.

La Segunda tras selecionar el Matrial y Obtener el precio pongo la cantidad en la Celda F24 y es en la celda H24 donde tengo la Segunda formula que da #N/A.

Cuando se introduce un Material de la Lista Todo Correcto, pero hay partes de la Factura que no hay que poner nada o escribir un Material manualmente y Entoces aparece #N/A.

Jorge L. Dunkelman 19 julio, 2008 09:59  

Hola Meteorito

mandame el archivo por mail.

Anónimo,  15 abril, 2009 13:37  

Hola Jorge,

He conocido tu página desde hace poco pero de momento ya me ha solucionado mas de un problema existencial. En el caso de la referencia #N/A en fórmulas vlookup, la había solucionado por otra vía mucho mas larga y "de estar por casa".
Tu solucion es práctica y elegante.

Muchas felicidades

Jon

Marvin 12 junio, 2009 18:23  

vaya!!
excelente post, gracias, de verdad... es bueno encontrar personas que tambíen publican cosas que benefician a otros y no se dedican solo a sacarle provecho al conocimiento de los demás.

el conocimiento le pertenece a la humanidad...

salu2

marvin

Anónimo,  26 junio, 2009 07:15  

Muchas gracias!!! pasé quebrandome la cabeza con esto pero tu explicación fue bastante clara y efectiva. Gracias

Anónimo,  05 agosto, 2009 06:54  

Excelente; muchas gracias por la explicacion, nunca supe como funcionaba la formula de que esta en el post pero ahora si me quedò muy claro; gracias otra vez

Anónimo,  06 octubre, 2009 05:11  

very good

Felicidadez por su Trabajo!!

Es la primer pagina que encuentro que me ayudo a solucionar mi problema.

thanks

Anónimo,  17 marzo, 2010 16:58  

Es correcto, la pagina es muy buena me acaba de ayudar.

Es importante diferenciar el uso de las funciones:
SI.ERROR y SI(ERROR())

Ya que la primera es sencilla, pero nos restringe a que si es VERDADERA la condicion la respuesta es el valor que se esta evaluando, por el otro lado la segunda nos permite decidir cual sera el valor a retornar si la condicion es VERDADERA O FALSA.

Gracias por publicarla.
Luis German Romero

Anónimo,  11 junio, 2010 22:43  

Sigo sin entender, en mi caso cuando tengo en mi lista alumnos depsarpobados me parece el escribir #N/A , pero si son aprobados o recuperan no, no se como resolver esto, se puede solucionar?? espero me respodas!!.
Mi mail es : cantaro@live.com.ar
Muchas gracias por la data =)Anahi

Jorge L. Dunkelman 11 junio, 2010 23:35  

Mandame el archivo por mail privado

Anónimo,  25 septiembre, 2010 10:07  

PERFEECTOO!! LE ENTENDI SUPEER! Y ME SALIO BIEN,RESOLVI MY PROBLEM,,MEEL GRAX!! =D
MOE BUENA PAGINA!! SALU2!! ;D

Anónimo,  25 septiembre, 2010 19:57  

Apreciado Jorge L. Dunkelman le felicito por crear y dedicarle tiempo a este blog. Es muy útil, práctico y, definitivamente muy valioso para los cibernautas que tenemos dudas con el manejo de esta herramienta. Dios le bendiga. Un afectuoso abrazo desde Colombia.

Anónimo,  23 mayo, 2011 16:28  

GENIALLLL! Muchas gracias! COn esta solución me quedó el excel muuucho mejor.
Muchas gracias!

Ximo 28 enero, 2012 11:33  

La verdad es que ha sido un gran alivio.A veces la solución está en buscar el error y no intentar evitarlo...Genial!!

Anónimo,  02 marzo, 2012 15:31  

Pasa el tiempo y es una duda recurrente para los que no tenemos tanto conocimento del excel. Muchas gracias!!

Anónimo,  02 junio, 2012 05:11  

GRACIAAAAAAAAAAAAAASS :)

Erick,  06 julio, 2012 02:01  

Muchísimas Gracias! Me hiciste quedar bien!

Anónimo,  20 septiembre, 2012 18:04  

Excelente ayuda, lo solucione sin problemas y en segundos. Muchas gracias!!

Anónimo,  28 enero, 2013 21:23  

GRACIAS EXELENTE AYUDA JJ COLOMBIA

Maraha Feijoo 03 febrero, 2013 16:18  

Muchisimas gracias por la ayuda. salu2

Anónimo,  04 abril, 2013 17:58  

excelente aporte me funciono perfecto!!!!!

Anónimo,  10 mayo, 2013 00:27  

=SI(BUSCARV(BUSCARV($E$4;Hoja1!$A$4:$BS$368;+D5);$A$147:$B$163;2);"")

a saber si uds pueden solucionar pues yo puse de mil formas y nada me sale bien, jejejeje

edviroc@hotmail.com

saludos

Danilo Delgado 05 junio, 2013 17:32  

IF(ISNA(f(X)),"default value","Correcta")

jorge,  08 agosto, 2013 09:08  

gracias me saco de un problema increíble.
gracias

Anónimo,  09 diciembre, 2013 18:27  

Se agradece el aporte. Me fue muy útil. Saludos

Anónimo,  31 enero, 2014 12:15  

muchas gracias después de mucho buscar esta ha sido la mejor respuesta

Anónimo,  20 marzo, 2014 22:24  

Excelente me ayudaste muchooooooooooooo O.o grax

JUSTO DE LA OSSA 05 septiembre, 2014 17:45  

Profesor!!! Dios te bendiga, me podrias colaborar si me haces el favor, como hago para que cuando haga un autollenado sobre una formula que necesito desplazar a las demas celdas, no me aparezca el mismo valor?
Es que estoy aprendiendo a hacer una hoja de kardex con promedio ponderado y al escribir la formula si sencilla al autollenar me aparece el mismo valor, ejemplo 2.800, 2.800, 2.800.
Gracias!

Jorge Dunkelman 06 septiembre, 2014 21:29  

Asegúrate que las referencias en las fórmulas sean relativas (sin los símbolos $).

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP