Encontrar el primer número positivo o negativo en el rango

domingo, marzo 03, 2013


En el pasado hemos tratado el tema de encontrar el último valor en un rango y también el último positivo o negativo.

Para encontrar el primer valor negativo en un rango podemos usar esta fórmula:

=INDICE($A$2:$A$15,COINCIDIR(VERDADERO,INDICE($A$2:$A$15<0,0,1),0))



Para hallar el primer número positivo en el rango usamos

=INDICE($A$2:$A$15,COINCIDIR(VERDADERO,INDICE($A$2:$A$15>0,0,1),0))

Sencillamente invertimos el signo "<" a ">"

La fórmula funciona de esta manera:

La expresión INDICE($A$2:$A$15<0,0,1) genera un vector de valores VERDADERO o FALSO



Luego  COINCIDIR(VERDADERO,INDICE($A$2:$A$15<0,0,1),0) nos da la ubicación de la primera aparición de VERDADERO en el vector



El resultado lo usamos como argumento en la función INDICE "externa"



obteniendo así el resultado



Podemos, también, obtener la dirección de la celda que contiene el valor combinando la función COINCIDIR con la función DIRECCION

=DIRECCION(COINCIDIR(VERDADERO,INDICE($A$2:$A$15<0,0,1),0)+1,1)


4 comments:

Juan Gabriel 03 marzo, 2013 21:07  

Excelente post, Jorge, ¡muchísimas gracias! Está bien clara la explicación

Manuel Cavero 04 agosto, 2016 12:06  

Una vez más Jorge, tengo que darte las gracias. Me has ayudado con un problema. Gracias

Enrique Muñoa del Pino 15 agosto, 2017 22:31  

EXCELENTE, PERO EN VERTICAL PERO HORIZONTAL NO ME SALE :(
=INDICE($A$1:$N$1,COINCIDIR(VERDADERO,INDICE($A$1:$N$1<0,0,1)))
32 29 26 23 20 17 14 11 8 5 2 -1 -4 -7 32

Jorge Dunkelman 16 agosto, 2017 16:18  

Hola Enrique,

tenes quemodificar la formula de la siguiene manera

=INDICE($A$1:$N$1,,COINCIDIR(VERDADERO,INDICE($A$1:$N$1<0,1,0),0))

Presta atencion a los cambios en la primer funcion INDICE (dos comas despues del primer arguumento) y en la segunda INDICE (el segundo argumentos es 1 y el tercero 0, al reves de la formula para rangos en columnas).

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP