Más sobre el extraño caso del signo más en Excel

miércoles, septiembre 12, 2012

En la nota anterior vimos el extraño caso del signo más en Excel, producto de los problemas de compatibilidad con Lotus 1-2-3




y mostramos la solución.

Pero sucede que esta solución tiene efectos secundarios, como me señala el amigo Sebastián, asiduo lector del blog.

Normalmente, si ingresamos el valor “28-8-2012” en una celda, Excel lo transforma automáticamente en la fecha 28/8/2012



Veamos que pasa después de marcar las opciones de compatibilidad con Lotus 1-2-3



Excel realiza la operación (28-8-2012 = -1992), en lugar de convertirlo en fecha.

A diferencia del caso anterior, esto no parece estar relacionado al formato de la celda. También si la celda tiene el formato General, Excel realiza la operación en lugar de poner la fecha.

8 comments:

Jorge 13 septiembre, 2012 19:51  

Hay otra situación cuando quiero ingresar en una celda por ejemplo la descripcion (3.5 litros) me da un mensaje de error en formula, al parecer esto se da cuando comienza con numeros si empieza con letra y despues numeros no da error.

Jorge L. Dunkelman 13 septiembre, 2012 20:37  

Si ingresas la descripción como fórmula (=3.5 litros, por ejemplo), se produce un error sin importar si se empieza por números o letras. ¿Podrías describir el error que recibes o mandarme una captura de pantalla por mail privado?

Jorge 13 septiembre, 2012 21:20  

En el caso anterior que le comentaba lo ingresaba sin el signo igual como si fuera texto y solo me da error si empiezo con numero. Antes de activar la casilla de introducción de formulas de transición no ocurria. A que correo puedo mandarle alguna captura de pantalla.

Jorge L. Dunkelman 19 septiembre, 2012 21:17  

Fijate en el enlace Ayuda en la parte superior del blog

ExcelFan,  19 septiembre, 2012 21:29  

Hola, excelente blog!
Sería genial saber cómo contar celdas que empiecen por números. Ejemplo: En la columna A tengo nombres de compañías (cada una en una celda diferente) 3D, Diesel, Telmex, 8bits, Aquarius, Lagrange, 77asociados, Consortium, etc. La idea es contar las empresas que empiezan por números. Interesante reto no? Saludos!

Jorge L. Dunkelman 19 septiembre, 2012 21:39  

Estimado, la consulta no está relacionada con el contenido de la nota, pero de todas maneras...suponiendo que la lista de empresas están en el rango E1:E8

=SUMAPRODUCTO(--(ESNUMERO(VALOR(EXTRAE(ESPACIOS(A1:A8),1,1)))))

ExcelFan,  20 septiembre, 2012 00:29  

Oh, genial! Excelente respuesta, gracias por responder tan pronto. Muchos ánimos para seguir con el blog y felicitaciones nuevamente. Saludos

Publicar un comentario

Google+ Followers

Seguidores

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP