Auditoría de fórmulas en Excel – señalar precedentes y dependientes

domingo, mayo 10, 2009

Ya hemos hablado en el pasado sobre la barra de auditoría de fórmulas. Es ésta una excelente herramienta para controlar y auditar las fórmulas en las hojas. Sin embargo, y de acuerdo a mi experiencia es poco usada y menos aún conocida por gran parte de los usuarios, incluidos aquello que se consideran usuarios avanzados.

En esta nota mostraremos sucintamente el rastreo de celdas precedentes y dependientes en un cuaderno de Excel.

Precedentes son celdas que afectan el valor de la celda inspeccionada. Dependientes son las celdas afectadas por la celda seleccionada. Veamos esto con un ejemplo



Excel auditoria de formulas


Excel auditoria de formulas

En Hoja1 tenemos una tabla de bonos que corresponden a intervalos de edades. En la hoja Nombres tenemos la lista de los nombres con sus respectivas edades.


En la celda E1 ponemos una lista desplegable con Validación de Datos, basada en la lista de nombres.

Excel auditoria de formulas

En la celda E2 ponemos la fórmula


=BUSCARV(E1,nombres!A2:B6,2,0)


que nos da la edad del nombre que aparece en la celda E1. Finalmente en la celda E3 ponemos

=BUSCARV(E2,A2:B7,2)


para determinar el bono de acuerdo a la edad.


Seleccionamos A7 (o cualquier celda en el rango A2:A7) y accionamos la opción Rastrear dependientes

Excel auditoria de formulas

Excel traza una flecha que indica que la celda E3 es afectada por el valor de la celda A7.

Excel auditoria de formulas

Ahora seleccionamos la celda E3 y activamos Rastrear Precedentes

Excel auditoria de formulas

Vemos que E2 es precedente de E3 (afecta su valor) y también todo el rango A2:B7 que además de la flecha aparece enmarcado con un borde de color azul.


¿Qué pasa cuando las celdas precedentes están en otra hoja? Ese es el caso de la fórmula en la celda E2 que es afectada por los valores de la tabla nombres en la hoja Nombres.
En ese caso Excel señala que se trata de una referencia remota poniendo una flecha y en su extremo el símbolo de una tabla.

Excel auditoria de formulas

Para ver las referencias a las celdas precedentes tenemos que apuntar con el mouse a la flecha (la figura del mouse cambia de una cruz a una flecha) y hacer un doble clic

Excel auditoria de formulas

Esto abrirá el menú de Ir A, donde podemos ver la lista de las celdas remotas que afectan a la fórmula

Excel auditoria de formulas

Podemos elegir una de las celdas de la lista y apretar aceptar para ir a la celda en cuestión.




Technorati Tags:

4 comments:

Andrés 12 mayo, 2009 16:30  

Siempre me había picado la curiosidad esta herramienta pero nunca me había llegado a molestar en usarla. Gracias por la explicación. Y mil enhorabuenas por este fantástico blog.

carlos 18 mayo, 2009 16:45  

Como esta Maestro, un gran saludo.
Mi consulta es la siguiente: ¿Como puedo lograr que al momento de crear una lista con una validacion de datos NO me incluya los espacios en blanco? Ejemplo:

Uno

Dos


Tres

...y si creara una lista en validacion de datos me incluiria los espacios entre cada palabra.
Espero haberme explicado y me pueda ayudar.

De antemano le agradezco su valioso tiempo y atenciones. Gracias!!!!

Danilo Chavez,  18 mayo, 2009 17:42  

Yo siempre uso esta herramienta para poder chequear mi matriz de trabajo. Sin embargo, por que no se puede rastrear tan facilmente como hacer doble click en la flecha cuando se trata de dependientes? o es que no he utilizado algo correctamente?

Jorge L. Dunkelman 19 mayo, 2009 20:51  

Carlos
fijate en la técnica que propongo en esta nota.

Publicar un comentario

Seguidores

Google+ Followers

Google+ Badge

Términos Legales

  © Blogger template On The Road by Ourblogtemplates.com 2009

Back to TOP